Resolved. Flutter requires Android SDK 28 and Android BuildTools 28.0.3

I’m interested of learning Flutter for Games Development so I started downloading all the required programs on my laptop. I have Windows 10 and MAC operating systems but for this install. I will use my Windows 10 Pro operating system as for my platform.

So I have to install Flutter, VS Code and Android Studio to begin. After 10-15 minutes of download and install, I encountered my first error when I run “flutter doctor” to check my installation.

It took a while to resolved this installation issue after hours of searching for solution. To save you time, here’s how I fixed this error.

  • Open your Android Studio, as of this date I am running released 3.3.2.
  • In Android Stuido, click on Tools, SDK Manager.
  • Click on SDK Tools, you should be in this page as depicted below.

I thought it is the Android SDK Tools installation. So I tried un-installing and re-installing multiple times but no luck.

You need to put a check on “Show Package Details” to see all status of version installed.

I selected all the version 28.0.n then click Apply to begin the installation. After that, I run “flutter doctor” again viola error is corrected.

There you go. I hope this save you time trying to fix your Flutter installation. Now, it’s time to code.

Leave a comment if you have any questions.

Image by TheDroidsonroids.com

Support @QUE.COM

Founder, QUE.COM Internet Media. | Founder, Yehey.com a Shout for Joy! | MAJ.COM Management of Assets and Joint Venture.. More at KING.NET Ideas to Life.

5 thoughts on “Resolved. Flutter requires Android SDK 28 and Android BuildTools 28.0.3

Leave a Reply to Thomas Cancel reply